python3错误:dyld: Library not loaded: @executable_path/../.Python

dyld: Library not loaded: @executable_path/../.Python
  Referenced from: /usr/local/bin/python3
  Reason: image not found
[1]    888 abort      python3

查看/usr/local/bin/python3 路径上是有python3的软链接的

网上找了一些解决办法,然而并没有什么用。

执行brew install python3 提示已经安装。

没办法,,,,

最后尝试执行brew upgrade python3解决问题。

发布了368 篇原创文章 · 获赞 178 · 访问量 47万+
展开阅读全文

带有框架的 iOS 应用程序在设备上崩溃,dyld: 库未加载,Xcode 6 Beta

06-20

<div class="post-text" itemprop="text"> <p>This crash has been a blocking issue, basically I used following steps to reproduce the issue:</p> <ul> <li>Create a Cocoa Touch Framework project</li> <li>Add a swift file and a class <em>Dog</em></li> <li>Build framework for device</li> <li>Create a Single View application in Swift</li> <li>Import framework into app project</li> <li>Instantiate swift class from the framework in ViewController</li> <li>Build and run app on device</li> </ul> <p>The app immediate crashed upon launching, here is console log:</p> <pre><code>dyld: Library not loaded: @rpath/FrameworkTest03.framework/FrameworkTest03 Referenced from: /var/mobile/Applications/FA6BAAC8-1AAD-49B4-8326-F30F66458CB6/FrameworkTest03App.app/FrameworkTest03App Reason: image not found </code></pre> <p>I have tried to build on iOS 7.1 and 8.0 devices, they both have the same crash. However I can build app and run on simulator fine. Also I am aware that I can change the framework to from <em>Required</em> to <em>Optional</em> in <em>Link Binary With Libraries</em>, but it did not completely resolve the problem, the app crashed when I create an instance of <em>Dog</em>. The behavior is different on device and simulator, I suspect that we can't distribute framework for device using beta version of Xcode. Can anyone shed light on this?</p> </div> <p>转载于:https://stackoverflow.com/questions/24333981/ios-app-with-framework-crashed-on-device-dyld-library-not-loaded-xcode-6-beta</p> 问答

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览